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About Scratch

With Scratch, you can program your own 
interactive stories, games, and animations � and 
share your creations with others in the online 
community.
Scratch helps young people learn to think 
creatively, reason systematically, and work 
collaboratively � essential skills for life in the 21st
century.

Who Uses Scratch?

Scratch is designed especially for ages 8 
to 16, but is used by people of all ages. 
Millions of people are creating Scratch 
projects in a wide variety of settings, 
including homes, schools, museums, 
libraries, and community centers.

Learn to Code, Code to Learn

The ability to code computer programs is an important part of literacy in today�s society. 
When people learn to code in Scratch, they learn important strategies for solving problems, 
designing projects, and communicating ideas.
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Concept of algorithm

To write a logical step-by-step method to solve the 
problem is called algorithm, in other words, an 
algorithm is a procedure for solving problems. In 
order to solve a mathematical or computer problem, 
this is the first step of the procedure. An algorithm 
includes calculations, reasoning and data processing.
Algorithms can be presented by natural languages, 
pseudo code and flowcharts, etc.

Dancing Cat Algorithm

Dancing Cat Program video

Algorithms: introduction

Definition

Informally, an algorithm is any well defined 
computational procedure that takes some 
value, or set of values, as input and produces 
some value, or set of values, as output. An 
algorithm is thus a sequence of computational 
steps that transform the input into the output.
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Various Concepts in Scratch
The various concepts that will be investigated in the sequel are the following ones :

1. Sequence of statements
2. Introduction to variables
3. Conditional statements
4. Loop statements
5. Manipulation of sets of values
6. Procedure and function
7. Toward object approach programming

Introduction to Scratch
Scratch is a free software

and web portal developed by the MIT
in order to allow kids tolearn how to
develop interactive stories and
animation in a collaborative manner.
In a Scratch project, you can control
sprites and make them move,
interact... But the language proposed
to control these sprites contain all the
basics structures necessary in any
algorithms. So Scratch can be used to
develop any kind of algorithms. In the
sequel, for each part there will be
exercises aiming at controlling the
sprites, but also exercises to design
more theoretical classical algorithms.
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Online Tools

The tool is available online at the address: 
https://scratch.mit.edu/. A wiki is also available: 
http://wiki.scratch.mit.edu/wiki/Scratch_Wiki. In addition,an 
offline editor is available: 
https://scratch.mit.edu/scratch2download/.
When you access the website, you can create a free account 
to save your projects. You can create a new project by 
clicking on the dedicated menu (Create), even if you have 
not an account.

Online Project

Scratch
Window
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Interface
The three main parts of the interface are:

on the left: the Graphical User Interface showing the execution of the algorithm.In particular, 
you can observe here the sprites, their moves ...;

in the center: the library of blocks (statements), that you can use to build the algorithm (in the 
right part);

on the right: where the algorithm will be written by putting together blocks.
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To build an algorithm, we only need to drag and drop elements from the block library to

the algorithm part.

Scratch Library

The library contains a huge set of block, 
ordered by categories. Each category has 
its own color. For example, all the blocks 
related to the sprite�s motion are blue.

Motion

Motion: blocks to move sprites (move, rotate,...)
and variables dealing with their position or 
direction.
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Move
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Looks:

blocks to modify the way the sprite looks like. It alsocontains blocks allowing sprites to say 
anything.

Sound?: everything related to sound.

Pen?: blocks allowing the sprite to write on the background.

Data: it allows to create new variables and lists. It provides also statements to manage them.

Events?: blocks to react to events, in particular when the user clicks on the green flag.
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Control?: blocks controlling the execution of the algorithm, e.g.conditionals, loops...

Sensing?: blocks dealing with interactions with the user, in particular with mouse clicks... It 
allows also sprites to ask users to give a value.

Operators?: blocks to do computation (addition, multiplication...), to choose a random number, 
concatenate two strings, compute conditions...

More blocks?: this allows to create new blocks, that will be used
to defined procedures

Solutions
1. Sequence of statements
2. Variables
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3. Conditional statements
4. Loop statements
5. Manipulation of sets of values
6. Sub-algorithm: procedure and function
7. Towards object /agent-oriented approach

Sequence of statements

The idea of sequential execution is this:

Exercise 1:
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Exercise 2:
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Variables

A simple way to think about variables is a box with numbers in it. These numbers can be 
increased and decreased and made to control various parts of a project. the variables in Scratch 
and other programming languages are simply known values. variables can contain text (strings),
numbers, or booleans (true/false values). Some examples are below:

Exercise 1:
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Exercise 2:

Exercice 3:
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Conditional statements:
The If () Then, Else block is a Control block and a C block. The 

block will check its boolean condition: if the condition is true, the code
held inside the first C (space) will activate, and then the script will 
continue; if the condition is false, the code inside the second C will 
activate (unlike the If () Then block).

Exercise:1
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Exercise 2:

Loop statements:
In programming, a loop can induce multiple executions of statements. In Scratch, any

block whose lael begins with "forever" or "repeat" is a looping construct.
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Exercise 1:

Exercise...2
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Exercise 3:
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Exercise: 4
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Manipulation of sets of values
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Sub-algorithm: procedure and function
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Exercise 2
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Towards object /agent-oriented approach
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Audacity.

Objective
The objective of this tutorial is to learn how to edit an audio file. To achieve this 

objective, we are going to import an existing sound file, remove all but 10 seconds of this file, 
apply a 1-second fade-out at the end, export the results, and play it in your favorite audio 
player. These steps will introduce the basic steps commonly used when editing the contents of 
an audio file.
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Find a file to edit

Audacity can import many common audio file formats, including WAV, AIFF, and MP3. If the 
optional FFmpeg library is installed, a larger range of formats, including WMA and the audio 
content of most video files, can be imported. Audacity cannot import copy-protected music 
files.If you want to edit music that you have on an audio CD, you need to "rip" the music into 
an audio file. See the Audio CDs page for information on getting the audio off of CDs and into 
Audacity.

Don't have any audio files handy? There is lots of free music online! Here is one site where you
can download free music: Opsound

The recordings on this site are free, distributed under the Creative Commons Attribution-
Sharealike license, which gives you the right to create a derivative work without paying 
royalties, as long as you give credit and make your derivative work free, too. This is similar to 
the license for Audacity, which allows any devloper to modify it and redistribute it for free.

Import the file into Audacity

First launch Audacity, then import an audio file by selecting 
File > Import > Audio....

A quicker method is to just drag and drop the file as in the 
following examples:

All three platforms support:

dragging the audio file into the Audacity window

dragging the audio file to the Audacity icon on the Desktop. 
Specific dragging behavior according to platform:

On Windows and Mac you can also drag to Audacity's icon in a file manager application.
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On Mac and Linux you can drag the file
to the Audacity icon in the Dock or 
Taskbar respectively to import the file 
into Audacity.

On Windows, dragging the file to the 
Audacity icon in the Taskbar will either
switch the window to Audacity if it is 
running (from where you can drag the 
file in), or if Audacity is closed, give 
the option to launch Audacity with the 
file imported.

Look at the waveform

This image above shows a stereo waveform. The left channel is displayed in the top half of the 
track and the right channel in the bottom half. The track name takes the name of the imported 
audio file ("No Town" in this example). Where the waveform reaches closer to the top and 
bottom of the track, the audio is louder (and vice versa).

The ruler above the waveform shows you the length of the audio in minutes and seconds.
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Export the resulting file

When you save an Audacity project with File > Save Project you are doing just that - saving an 
Audacity project. Audacity projects can be opened only by Audacity. If you want other 
applications (such as iTunes or Windows Media Player) to be able to open this file you need to 
export it.

Before we export this 10 second clip to a separate file we're going to simplify things a bit. Go to
the Import / Export Preferences, and under When exporting tracks to an audio file uncheck 
"Show Metadata Editor prior to export step". Metadata Editor adds extra information about the 
speech or music into the file - see For More Information below to learn more. You can go back 
to the Import / Export Preferences at any time to re-enable Metadata Editor.

Exporting a WAV file

Click on File > Export Audio... - the standard "Save" dialog for your operating system appears.

Give the file a different name. Audacity always suggests a name for the file that is the same as 
the name of your Audacity project. It is always best to alter this so you do not confuse your 
exported file with your Audacity project.

Choose a location to save the file in the usual manner.

At the bottom of the Save dialog is a dropdown menu labeled "Format". From this menu choose
"WAV (Microsoft) signed 16-bit PCM".

There are no options for the WAV file format, so there is no need to click the Options button.

Click the Save button to complete the export of your project to a WAV file.

Exporting an MP3 file

In order to export files from Audacity in MP3 format you will need to download and install the 
optional LAME MP3 encoder. Instructions are here . Once you have downloaded and installed 
the LAME encoder you will be able to create MP3 files using Audacity.

The steps for exporting a file in MP3 format are the same as for a WAV file, except:

In the Save dialog, from the "Format" menu, choose "MP3 files"

Then click the Options button to set the bit rate and other options for the MP3 file.
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Testing your new Audio Production

To demonstrate the difference between an Audacity project (the AUP) file, and a sound file you 
export from an Audacity project:

Click on File > Close, saving changes if asked.

Find the AUP file on your computer and attempt to open it with the audio player of your choice 
(for example iTunes, Windows Media Player). You cannot.

Find the exported WAV file on your computer and attempt to open it with the audio player of 
your choice. Success!

You cannot open an Audacity project in a media player. Only by exporting your project can you
listen to it in a media player.

Once you've exported your project you may want to keep the original project file (AUP) and its 
associated _data folder around in case you want to make some changes to it in the future.

Making a Test Recording

Step 1: Turn on monitoring

Step 2: Start the recording

Step 3: Adjust the level

Step 4: Test recording

Recording and Editing

Step 1: Record for real this time

Step 2: Edit Recording

Step 3: Amplitude adjustment

Step 4: Save and Export

Edit Recording
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You now have a good recording, but there are likely some bits at the beginning and end that you
do not need - between the time you clicked the Record button and the time you starting talking 
or playing, and between the time you stopped talking or playing and the time you clicked the 
Stop button.

Click the Skip to Start button image of the Rewind button in Transport Toolbar Repeatedly 
click the Zoom In button image of the zoom in button until the displayed waveform expands so 
you can see from the beginning of the recording to the time you started talking or playing

With the Selection tool SelectionPointer.png , click just before the point where you started 
talking or playing

Choose Edit > Select Track Start to Cursor

The region from the beginning of the track to the beginning of your performance is selected

Choose Edit > Delete

The selected audio is removed from the track, and the rest of the audio moves left to fill the 
space left after the delete.

Similarly, you can delete the extra bit from the end of your recording.

Click the Skip to End button image of the fast forward button in Transport Toolbar

Repeatedly click the Zoom In button image of the zoom in button button until the displayed 
waveform expands so you can see from the time you stopped talking or playing to the end of 
the recording

With the Selection tool SelectionPointer.png , click just after the point where you stopped 
talking or playing

Choose Edit > Select > Cursor to Track End

The region from the end of your performance to the end of the track is selected
Choose Edit > Delete

The selected audio is removed from the track
If you've made any mistakes in your performance you could edit them out. Use the 

Selection Tool to select each mistake and press the delete key. Listen back to each edit to make 
sure it sounds natural. If not, choose Edit > Undo Delete and try again
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Amplitude adjustment
Since you were careful not to record too loud it is likely that your recording is not as loud as 
possible. To correct this you can use the Normalize effect.

Choose Edit > Select > All (or use CTRL + A) to select all of the track.

With default Tracks Preferences, you may not need this step - all the audio in the project is 
selected if you choose an effect without first selecting any audio.

Choose Effect > Normalize....

Accept (for now) the default choices in the Normalize dialog and click the OK button

The volume is normalized to -1 dB, so leaving a little headroom below the maximum possible 0
dB level.

Note that Normalize defaults to retaining the existing balance between stereo channels. 
However basic consumer-level equipment can often record with channels unbalanced. To 
correct unwanted volume differences between left and right, check "Normalize stereo channels 
independently".

Save and Export

Choose File > Save Project, then choose a name for your project and a place to save it.
You have now saved an Audacity Project to disk. The project file (ending in .aup) can only be 
opened by Audacity. You can come back to the project and make changes to it later. For 
example you could do more editing, record more audio, or apply other effects.
To listen to your performance in other audio software (such as iTunes or Windows Media 
Player), or to burn it to CD, choose File > Export....

video help


